• Symptom:
    {
      "error": {
        "code": "HOST.1009",
        "description": "Failed to migrate vm on hypervisor",
        "details": "failed to migrate vm[uuid:90bb61f55e774f5f89c9e1ea46db7661] from kvm host[uuid:e5105c61114a4efe8bcc025f744226bd, ip:10.0.247.244] to dest host[ip:10.0.197.238], unable to migrate vm[uuid:90bb61f55e774f5f89c9e1ea46db7661] to qemu+tcp://10.0.197.238/system, internal error: Attempt to migrate guest to the same host localhost.domain.com"
      },
      "createdTime": 1488170137857,
      "type": {
        "_name": "key.event.API.API_EVENT"
      },
      "id": "e6bcd7c33ad9446b919e11cd647fc8dc"
    }
  • Cause:

    Two hosts have the identical hostname. Migrating a KVM VM instance depends on a hostname for confirming hosts. If the hostnames duplicate, ZStack deems that the same host is used.

  • Solution:

    We recommend that you set different hostnames for different hosts. If the preceding errors are reproduced, contact our official technical support.